[Rails5.2]Globalizeのインストールでエラー

公式リボジトリ通り進めると bundle install でエラーが発生する

対応方法

gem 'globalize', '~> 5.2.0'

公式リポジトリには、

gem 'globalize', '~> 5.1.0'

とあるが、そのまま bundle install すると、下記のようなエラーがでる。

Bundler could not find compatible versions for gem "activemodel":
  In snapshot (Gemfile.lock):
    activemodel (= 5.2.2)

  In Gemfile:
    carrierwave (~> 1.0) was resolved to 1.3.1, which depends on
      activemodel (>= 4.0.0)

    globalize (~> 5.1.0) was resolved to 5.1.0, which depends on
      activemodel (>= 4.2, < 5.2)

    rails (= 5.2.2) was resolved to 5.2.2, which depends on
      activemodel (= 5.2.2)

    simple_form was resolved to 4.1.0, which depends on
      activemodel (>= 5.0)

Running `bundle update` will rebuild your snapshot from scratch, using only
the gems in your Gemfile, which may resolve the conflict.

activemodelが >= 4.2, <5.2 に引っかかっているっぽい
なので、globalizeのバージョンを上げたら可能だった。

2018/11/21に5.2.0がリリースされている。現時点で最新版なので、こちらを利用することにした。

公式リポジトリに、下記のように記載があるが、gitから取得する方法だと現時点で5.3.0になり、プレリリース版なので見送る

Please help us by letting us know what works, and what doesn’t, when using pre-release code.
Put in your Gemfile

gem ’globalize’, git: ’https://github.com/globalize/globalize’
gem ’globalize’, git: ’https://github.com/globalize/globalize’ gem ’activemodel-serializers-xml’

https://github.com/globalize/globalize

コメント